WordPress, Popüler AMP Eklentisinin Kusurları Düzeltiyor

Bir güvenlik araştırmacısı, düşük öncelikli bir saldırganın hedeflenen web sitesinin AMP sayfalarına kötü amaçlı kod yerleştirmesine olanak tanıyan , WordPress için yaygın ve yaygın olarak etkin olan eklentilerden birinde kritik bir güvenlik açığının ayrıntılarını açıkladı .

Söz konusu savunmasız WordPress eklentisi, web sitelerinin blog gönderileri ve diğer web sayfaları için otomatik olarak geçerli hızlandırılmış mobil sayfalar oluşturmasına olanak sağlayan ” WP – Hızlandırılmış Mobil Sayfalar için AMP ” dir. Hızlandırılmış Mobil Sayfalar’ın (AMP) temsil ettiği AMP , Google tarafından, web sitelerinin mobil web sitelerine daha hızlı web sayfaları oluşturmasına ve sunucuyu oluşturmasına izin vermek için tasarlanmış açık kaynaklı bir teknolojidir.

WordPress web sitelerinin Google optimizasyonlu AMP sayfaları oluşturmasına olanak tanıyan yüzlerce eklentiden, “WP için AMP”, 100.000’den fazla kurulumu olanların arasında en popüler olanıdır. Etkilenen eklenti, yakın zamanda, savunmasız kod nedeniyle WordPress eklentileri kitaplığından geçici olarak kaldırıldı, ancak ne geliştiricisi ne de WordPress ekibi eklenti konusundaki kesin sorunu ortaya çıkarmadı.

Web güvenlik firması WebARX’ten siber güvenlik araştırmacısı Luka Sikic, güvenlik açığı olan eklenti sürümünü analiz etti ve daha sonra güncellenmiş sürümünde yamalanmış olan “WP için AMP” de bir kod-enjeksiyon güvenlik açığı tespit etti. Bu güvenlik açığı, “WP – Accelerated Mobile Pages” eklentisi için AMP’nin kullanıcı hesapları ve WordPress AJAX kancaları için izinleri işleme biçiminde kalıyordu. “AMP eklentisi güvenlik açığı, kurulum sihirbazı sırasında ayarları kaydetmek için çağrılan ampforwp_save_steps_data’da bulunuyor.”  “Bu özel eklenti güvenlik açığı, kullanıcı kaydına izin veren web siteleri için kritik bir sorundur.” Eklenti altında, eklenti bir AMP sayfasının üstbilgisinde veya altbilgisinde reklam ve özel HTML / JavaScript kodu eklemek için web sitesi yöneticileri seçeneklerini sunar. Bunu yapmak için eklenti, arka planda WordPress ‘yerleşik / AJAX kanca işlevselliğini kullanır.

Bir WordPress sitesindeki her kayıtlı kullanıcı, en düşük ayrıcalıklarla bile, AJAX kancalarını arama yetkisine sahip olduğundan ve savunmasız eklenti, AJAX kancalarını arayan hesabın yönetici olup olmadığını kontrol etmediğinden, sitenin herhangi bir kullanıcısı yapabilir. özel kodun enjekte edilmesi için bu işlevin kullanılması.

Araştırmacı, “Güncellenen sürümde, eklenti wpnonce değerini kontrol ediyor ve kullanıcı oturum açıp açamadığını kontrol edebiliyor.” Diyor. WordPress web siteniz de etkilenen eklentiyi kullanıyorsa, mümkün olan en güncel güvenlik güncellemelerini en kısa zamanda yüklemeniz önemle tavsiye edilir. Bu ayın sadece 15’i ve başka bir popüler WordPress eklentisindeki zayıflık, yüz binlerce web sitesini etkiledi. Geçtiğimiz hafta, kötü niyetli veya güvenilen ayrıcalıklı bir kullanıcının WordPress web siteleri üzerinde tam kontrol sahibi olmasını sağlayan popüler bir WooCommerce eklentisinde , keyfi bir dosya silme güvenlik açığı açıklandı .

Bir Cevap Yazın

Please log in using one of these methods to post your comment:

WordPress.com Logosu

WordPress.com hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Google fotoğrafı

Google hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Twitter resmi

Twitter hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Facebook fotoğrafı

Facebook hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Connecting to %s