Linux, Red Hat, Amazon Ve Azure Kullanıcıları Yeni Güvenlik Açığından Etkilendi

Linux sistem kullanıcıları yeni bir tehditle karşı karşıya. Ağ güvenliği ve Uluslararası Siber Güvenlik Enstitüsü’nün etik kesen uzmanlarına göre, Docker, cri-o, containerd ve Kubernetes ile çalışan runC çalışma zamanı container işlevini etkileyen kritik bir güvenlik açığı tespit edildi. RunC, konteyner oluşturmak ve yürütmek için Açık Konteyner Girişimi için uygun bir komut satırı arayüz aracıdır.

CVE-2019-5736 olarak izlenen güvenlik açığı, virüslü bir kapsayıcının runC ikili dosyasının üzerine yazmasına ve ana bilgisayardaki kök dizinine erişmesine izin verir. Başka bir deyişle, bu virüs bulaşmış kabın küresel konağın kontrolünü ele geçirmesine izin verecek, böylece saldırganlar herhangi bir komutu yerine getirebilecektir. Bir siber güvenlik uzmanı, “Yöneticiler önceden işlem yapmamışsa, çalışma zamanı kapsayıcısının çoğunun bu güvenlik açığından etkilenmesi muhtemeldir” dedi. Uzman, güvenlik açığının “kök, kullanıcının ad alanında eşlenmemiş olduğu” kullanıcı ad alanlarının düzgün bir şekilde uygulanmasıyla engellendiğini ekledi. Güvenlik açığı, bazı ağ güvenlik uzmanları tarafından kritik olarak kabul edilmiştir . Uzmanlar, bu güvenlik açığının CVSS ölçeğinde 7.2 / 10 puan aldığını belirtti.

En son günlerde, runC kullanıcılarına gönderilen güvenlik açığını düzeltmek için bir yama geliştirilmiştir. Ek olarak, birkaç bulut servis sağlayıcısı güncelleme düzeltme ekini uygulamak için adımlar atıyor. Kubernet ekosistemine özgü olmamakla birlikte, güvenlik açığı, geçen yıl platformda bulunan kritik bir hatanın davranışını takip ediyor gibi görünüyor. Hata, tüm Kubernetes tabanlı ürün ve hizmetleri etkilemiş ve bir Kubernetes kümesinde çalışan herhangi bir düğümdeki bilgisayar korsanlarına yönetici ayrıcalıkları vermiştir. Güncelleme yaması hızla geliştirilip yayınlansa da, ağ güvenliği uzmanları hala daha fazla güvenlik açığının ortaya çıkmasını bekliyor. “Yeni güvenlik açıkları sonsuza kadar görünmeye devam edecek” dedi. “Gelecekte daha fazla olmaları bekleneceği için bu tür bir hatayı bulmamız beklenecekti, yazılımın gerçek bir kalitesidir”.

Geçen yıl, 21 binden fazla API yönetim sistemi ve açık konteyner olası siber saldırılara karşı savunmasız bulundu. Maruz kalan sistemler arasında Kubernet, Swarm, Red Hat uygulamaları da vardı. Ayrıca Linux kullanıcı topluluğunu ilgilendiren bilinen güvenlik açıkları Spectrum ve Meltdown ile bağlantılı yongalarda da ciddi güvenlik sorunları var.

Bir Cevap Yazın

Please log in using one of these methods to post your comment:

WordPress.com Logosu

WordPress.com hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Google fotoğrafı

Google hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Twitter resmi

Twitter hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Facebook fotoğrafı

Facebook hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Connecting to %s