LibSSH Kusurları Hackerların Şifresiz Sunucuları Devralmasına İzin Verir

Libssh olarak bilinen Güvenli Kabuk (SSH) uygulama kitaplığında dört yıllık ciddi bir güvenlik açığı bulunmuş olup , bu sayede herhangi bir parola gerektirmeden savunmasız bir sunucu üzerinde kimlik doğrulamasını tamamen atlatıp sınırsız bir yönetim denetimi kazanmış olabilir.

CVE-2018-10933 olarak izlenen güvenlik açığı, 2014’ün başında yayımlanan Libssh sürüm 0.6’da kullanıma sunulan bir kimlik doğrulama atlamasıdır ve son dört yıldır binlerce kurumsal sunucu hacker’lara açıktır.

Fakat korkmadan önce, ne yaygın olarak kullanılan OpenSSH ne de Github’un libssh uygulamasının bu güvenlik açığından etkilenmediğini bilmelisiniz.

Güvenlik açığı Libssh’teki bir kodlama hatasından kaynaklanıyor ve istismar etmek için “gülünç derecede basit”. Salı günü yayınlanan bir güvenlik danışmanına göre , bir saldırganın “SSH2_MSG_USERAUTH_REQUEST” iletisi beklediğinde SSH bağlantısı etkinleştirilmiş bir sunucuya “SSH2_MSG_USERAUTH_SUCCESS” mesajı göndermesi gerekiyor.

Libssh’deki mantıksal bir kusur nedeniyle, kütüphane, gelen “başarılı giriş” paketinin sunucu veya istemci tarafından gönderilip gönderilmediğini doğrulamamakta ve ayrıca kimlik doğrulama işleminin tamamlanıp tamamlanmadığını kontrol edememektedir.
Bu nedenle, uzak bir saldırganın (istemci) libssh’e bu “SSH2_MSG_USERAUTH_SUCCESS” yanıtını gönderirse, kimlik doğrulamanın başarılı olduğunu ve saldırganın parola girmesine gerek kalmadan sunucuya erişim izni vereceğini düşünür.

GitHub, libssh kullanmasına rağmen, resmi web sitesinin ve GitHub Enterprise’ın, GitHub’un kitaplığı nasıl kullandığı nedeniyle bu güvenlik açığından etkilenmediğini doğrular.

Bir GitHub güvenlik yetkilisi Twitter’da; “Biz libssh özel bir sürümünü kullanın; biz kütüphane kullanımı ne pubkey tabanlı kimlik doğrulama, için güvenerek değil libssh sunucusu ile SH2_MSG_USERAUTH_SUCCESS,” söyledi, “Yamalar çok dikkatli bir şekilde uygulandı, ancak GHE [GitHub Enterprise] asla CVE-2018-10933’e karşı savunmasızdı.”

Shodan araştırması, internete bakan 6,500 sunucunun Libssh’ın ya da başka bir şekilde kullanılmasından dolayı etkilenebileceğini gösteriyor.

Güvenlik hatası, sorunu Libssh’e açıklayan NCC Group’tan Peter Winter-Smith tarafından keşfedildi.

Libssh ekibi, Salı günü güncellenen libssh sürümleri 0.8.4 ve 0.7.6 sürümüyle ilgili sorunu ele aldı ve aynı zamanda güvenlik açığının ayrıntıları da yayınlandı.

Web sitenize Libssh yüklüyse ve temel olarak sunucu bileşenini kullanıyorsanız, en kısa zamanda güncellenmiş Libssh sürümlerini yüklemeniz önerilir.

Bir Cevap Yazın

Please log in using one of these methods to post your comment:

WordPress.com Logosu

WordPress.com hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Google fotoğrafı

Google hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Twitter resmi

Twitter hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Facebook fotoğrafı

Facebook hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Connecting to %s